Custom taxonomy 不显示在 “外观”-> “菜单”里

7
56
Custom taxonomy is not showing in nav menu

I have a custom taxonomy registered for custom post type. It has ‘public’, and ‘show_in_nav_menus’ arguments set to true, but it still doesn’t appear in nav-menus.php. If I set those arguments to custom post type, it works all right… what could be the problem?

我为新文章类型(custom post type)注册了一个新的分类(register_taxonomy),’show_in_nav_menus’ 都设置为 ‘true’,但是在 “外观”-> “菜单” (nav-menus.php)里没有显示出来。可是新文章类型(custom post type)显示了,这是为什么?

好吧,看下图你或许就明白了!
But don’t forget checked it in Screen options:

Custom taxonomy is not showing in nav menu

7 COMMENTS

  1. You actually make it appear really easy together with your presentation but I to
    find this matter to be really one thing which I believe I would never understand.

    It kind of feels too complex and extremely vast for me.
    I am looking forward to your subsequent post, I’ll attempt to get
    the grasp of it!

  2. Thank you for sharing your thoughts. I truly appreciate your efforts and I am waiting for your further post thanks
    once again.

  3. facebook find love –
    Having read this I believed it was really informative.
    I appreciate you spending some time and energy to put this content together.

    I once again find myself spending a significant amount of time both reading and leaving comments.

    But so what, it was still worth it!

  4. Hi! I just want to offer you a huge thumbs up for your excellent information you have here on this post.

    I’ll be coming back to your web site for more soon.

  5. Very nice post. I just stumbled upon your weblog and wished to say that I’ve really enjoyed browsing your blog posts.
    In any case I’ll be subscribing to your feed and I hope you
    write again soon!

LEAVE A REPLY

Please enter your comment!
Please enter your name here